Blog
-
Adding a Child Domain Using Windows Server 2003 vs Windows Server 2008 R2
If you’ve ever had to add a new domain tree to an existing domain in Active Directory using Windows Server 2003 you may have already realized that you must have DNS configured properly before creating the new child domain. Put another way, if you didn’t know what you were doing you could get into trouble…
-
Reading a Remote Registry Key Through Scripting
I’ve been working a lot lately with SCCM DCM (System Center Configuration Manager Desired Configuration Manager). If you’ve worked with ConfigMgr you know how powerful the tool is. The DCM portion of ConfigMgr is particularly powerful when scanning collections for compliance against a set of baselines (comprised of configuration items). The one thing that you…
-
Using Sysinternals’ Process Monitor to Troubleshoot a Known Unknown
I was recently tasked to determine why the ASP.NET State Service would not start on a Windows 2003 Terminal Server. All I had to go by was the error message, “Error 5: Access is denied.” In addition to the above error message a cryptic Event 532 was being logged in the security log of event…
-
Running a Command Prompt as NT AUTHORITY\SYSTEM
I recently ran into a situation where I was using the SysInternals tool ProcDump to write a dump file to be examined for a memory leak. The problem started when trying to run ProcDump against the process oracle.exe. The error message was “Access denied.” I was an administrator on the server so how could I…
-
My Vonage Experience
In early December 2010, I decided to give Vonage a try. Why would I want to switch from a service that I had been using since 1994 and had essentially treated me with no problems? The simple answer is the outrageous amount that AT&T charges for their service. Below is a screenshot of my local…
-
How To Successfully Virtualize SBS 2003
A friend and colleague recently went through trials, tribulations, weeping and gnashing of teeth in an attempt to virtualize SBS 2003 to more easily provide an upgrade path to SBS 2008. His first and subsequent attempts at using Disk2vd were unsuccessful resulting in a black screen at boot. I was surprised at this because I…
-
Proxying requests to the published site using ISA Server or Threat Management Gateway
In ISA Server 2004\2006 or Forefront Threat Management Gateway 2010 the “Proxy requests to published site” setting is one of the most confusing yet simple configuration options when publishing a server. When you publish a website using the website publishing rule feature the default setting is to select the “Requests appear to come from the…
-
TMG vs UAG Confusion
Are you confused about the functional differences between TMG (Threat Management Gateway) and UAG (Unified Access Gateway)? You’re not alone. Thomas Schinder (MSFT) sums it up nicely by mentioning that UAG is designed to be an Enterprise solution for remote access into internal corporate resources without supplying any outbound access. TMG is designed for both…